There seems to be a bug in vSphere 6.7 that whenever you update you vCenter appliance, that the e-mail notifications from vCenter no longer works. You had previously set-up alarm definitions that sent an e-mail to a recipient when the alarm is triggered, but you don’t receive the e-mail message. There are no error messages in vCenter, you just don’t receive any mail alerts anymore.

You can correct this by temporary editing the SMTP server entry in vCenter and then edit the entry again to the original SMTP server.

vCenter SMTP settings

Detailed instructions:

  • Log on to the HTML-5 Web Client or the Flex client
  • Select your vCenter instance then browse to Configure – Settings -General
  • Under vCenter Server Settings you will see your configured mail configuration
  • Choose Edit (at the right top of the screen) and select Mail in the Edit vCenter general settings
  • Edit your Mail server to something different, doens’t matter that it doesn’t exist, just as long as the current entry get modified.
  • Click Save and repeat the same and now re-enter your original mail server configuration
  • After that, e-mails should be working again.
  • This issue could also be existing on vCenter 6.5, I’m not sure.
Edit vCenter general settings

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>